Push notifications not received on iPhone
Are your push notifications on your iPhone or iOs device not coming through? Does your phone not alert you when thresholds are crossed?
This article details why push notifications from your Growboard may not be working and how to fix the situation.
Root cause
The Growboard is a web-based app, meaning it is dependent on multiple layers of notification permissions from your phone. The three layers of permissions are:
- Growboard notification settings
- iPhone settings > Notifications settings
- Safari-browser notification settings
All three must be enabled for the push notifications to come through.
Fixes
First, make sure all three notification settings are enabled.
Growboard:
Navigate to Settings -button
from the menu on the left on your Growboard and choose 'Notifications'

You should see the view below. Tick the 'Push notification' box and the 'Push notifications on this device' toggle. Click 'OK' from the bottom right to confirm the activation.

iPhone:

Go to 'Settings' > 'Notifications' and make sure both the 'Allow Notifications and 'Time-Sensitive Notifications' are both on.
Also choose to have your chose alert styles on.
Safari:
Go to your iPhone Settings and navigate to the Safari app section. Scroll down and click on 'Advanced'. Scroll down again and click on 'Feature Flags'.

Scroll down until you see 'Notifications' and click on the toggle to turn it green.

If all toggles/permissions are on but no notifications come through, we kindly advise to turn all of them off and shut down all apps. After this, please turn all the notification permissions back on. This will create a new push notification token in the system.
If the issue persists even after turning them all off and on again, please contact support@growficient.com.